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Objective:  Depth-Convert Seismic Traces (Part 1) and Horizon and Fault Interpretation (Part 2) 

so that the depth-converted interpretation products consistently match the depth-
converted seismic traces 

 
 
Part 1:  Depth-converting seismic trace data 
 
Option 1:  Depth-Converting Seismic Traces Using Shared T/D Chart: 
(this approach may be used in the event that velocity trace data are lacking) 
  

Prior to begining:  Edit, resample, smooth sonic and density log curves 
   Generate a synthetic tie to the seismic data 
   Save the time-depth relationship as a shared T/D Chart 
  

Perform the depth conversion of Amplitudes (time) traces in TracePAK: 
 
 Project > TracePAK > Time < > Depth Conversion:   

Select line (survey) and input data type:  Amplitudes (Time), then Next… 
Select output data type:  AmplitudesDepth (Depth) or create new type, Next… 
Select Conversion Velocity as “Shared Time-Depth Chart”, 
Select specific Shared Time-Depth Chart, (if none, then perform sharing) 
Verify correct output sample interval and replacement velocity, then Next… 
Then Apply or Finish 
Save new traces with 8-bit or 32-bit resolution, as desired, then OK 

 “Progress” dialog shows activity until the processing is finished 
 
 
Option 2:  Depth-Converting Seismic Traces Using Average Velocity trace data: 
(a method for depth-converting seismic time traces if interval velocity trace data are lacking) 
  

Background:  Average velocity trace data (typically Vrms velocities) may be generated 
from DMO stacking velocities which are a necessary part of any seismic processing 
workflow and may be requested in SEG-Y format from your processor.  Average velcity 
(Vavg) traces are typically more smoothed than interval velocity (Vint) traces that may 
also be available from your processor.   

 
Perform the depth conversion of Amplitudes (time) traces in TracePAK: 

 
 Project > TracePAK > Time < > Depth Conversion:   

Select line (survey) and input data type:  Amplitudes (Time), then Next… 
Select output data type:  AmplitudesDepth (Depth) or create new type, Next… 
Select Conversion Velocity as “Average Velocity Volume”, 
Select the specific Vavg trace data type that is available,  
Evaluate Maximum Z value and select velocity units (ft/s or m/s), 
Verify correct output sample interval and replacement velocity, then Next… 
Then Apply or Finish 
Save new traces with 8-bit or 32-bit resolution, as desired, then OK 

 “Progress” dialog shows activity until the processing is finished 



 
 
Option 3:  Depth-Converting Seismic Traces Using Interval Velocity trace data: 
(this is the preferred workflow for depth-converting seismic time traces) 
  

Background:  Interval velocity trace data may be generated from DMO stacking velocities 
which are a necessary part of any seismic processing workflow and may be requested in 
SEG-Y format from your processor.  They are typically less smoothed than average 
velocity traces that may also be available from your processor.   

 
1)  Perform the depth conversion of Amplitudes (time) traces in TracePAK: 

 
 Project > TracePAK > Time < > Depth Conversion:   

Select line (survey) and input data type:  Amplitudes (Time), then Next… 
Select output data type:  AmplitudesDepth (Depth) or create new type, Next… 
Select Conversion Velocity as “Interval Velocity Volume”, 
Select the specific Vint trace data type that is available,  
Evaluate Maximum Z value and select velocity units (ft/s or m/s), 
Verify correct output sample interval and replacement velocity, then Next… 
Then Apply or Finish 
Save new traces with 8-bit or 32-bit resolution, as desired, then OK 

 “Progress” dialog shows activity until the processing is finished 
 
 
Part 2:  Depth-converting horizon and fault interpretation  
 
Option 1:  Depth-Converting Horizons using Average Velocity trace data: 
 

Extract Average Velocity (time) data type: 
 

Horizons > Extract Data Type   
Select horizon name and Vavg data type to extract (typically this is Vrms) 
Click “Apply” and iterate for other horizons, “OK” to finish 

 
Extended Math Calculator:  
 

Tools > Calculators > Extended Math  
Double-click to select and expand the Input Surface to be depth-converted 
Highlight the “Time” attribute and click >> A to select as Variable A 
Highlight the “Vrms” attribute and click >> B to select as Variable B 
Formula is (A * B) / 2 (because of two-way time) 
Select Output Surface Name and Color (both may be same as Input)  
Select “Depth” as the attribute or “Z” type 
Click “Compute” to perform the calculation  
Iterate for each horizon and then click “Cancel” to close the dialog 
The depth-converted horizons should now be visible in the depth displays 

 
 
Option 2:  Depth-Converting Horizons and Faults using Interval Velocity trace data: 

 
Summary Workflow:  This workflow contains 2 main and several subsidiary workflows:  
 
1) Depth-converting horizon interpretation 

a. Creation of T-D data type 
b. Extraction of T-D data type for each horizon 
c. Reassignment of T-D data type to Depth data type for each horizon 



 
2) Depth-converting fault interpretation 

a. Creating / loading pseudowells 
b. Extracting T-D data as single traces / loading as TD Charts for  pseudowells 
c. Depth-converting faults using shared TD Charts 
 

 
Detailed Workflow:  Step-by-step description of summary workflow:  
 
1a)  Depth-Converting Horizons Using Vint (time): 

 
 We must calculate a time-depth trace relationship from the Vint (time) traces  

(This is a two-part process) 
 Part 1:  Project > TracePAK > Process Multiple Traces:  Select line & Vint (time) traces  
  Select Process > Running Sum:  Save output as new data type: RS_Vint (time) 
 Part 2:  Project > TracePAK > Trace Calculator:   

Select input survey and data type RS_Vint (time), click to define variable >> A 
Formula is:  A * 0.002   ( if 0.004 sample interval), or 
Formula is:  A * 0.001   ( if 0.002 sample interval) 
Select output survey and save as new data type:  call it “T-D” (time) 

 
The following spreadsheet shows an example trace extracted from a test project that illustrates 
the calculations that convert the Vint traces into Time-Depth traces.  This is effectively interval 
velocity summation scaled to produce isopach summation (final calculation has m/s * s = m).   
 
TWTT  = the input time series, in this case, with a sample interval of 0.002 sec 
Vint  = the input interval velocity value for each corresponding time sample 
RS_Vint  = the running sum of the interval velocity (interval velocity summation) 
T-D   = the “scaled” running sum, equal to summed depth for each time sample 
 
 

 
 

Figure 1:  Spreadsheet illustrating algorithm for calculating T-D trace data from Vint trace data  
 
 

1b)  Extract T-D data type (time domain): 
 

Horizons > Extract Data Type > Select horizon and data type >  T-D (Time) 
 



Click “Apply” and iterate for other horizons, then click “OK” to finish 
 
 
1c)  We need to use the Horizon Properties dialog in order to reassign the horizon 

attribute type: 
 

Horizons > Properties: 
 

Select horizon > Click “Set” to set data type, then  
 
Select Data Type in Horizon > T-D (Time), then 
 
Set New Type > Depth (Depth) 
 
Click “Apply” to iterate for other horizons, then click “OK” to finish 
 
The depth horizons should now display with depth traces in a vertical profile. 

 
 
2)  Depth-Converting Faults Using Local or Shared T/D Chart(s) 
 
(Note:  There are two initial data / functionality requirements that must be considered): 
 
Assigned vs Unassigned faults:  To depth-convert unassigned fault segments they must first be 

assigned to an appropriate named fault plane (such as F-1, F-2, etc) or else they 
must all be assigned to a single named fault plane (such as “All Unassigned Faults”).  
The latter option is functionally quite acceptable even though the unassigned fault 
segments may not have any geological affinity to one another.  Fault segments may 
be unassigned from the named fault plane once the depth conversion is completed. 

  
Well Data:  Presence / Absence:  KINGDOM requires the use of TD Charts loaded in wells to 

perform depth conversion of faults.  If well data are lacking there are two clear 
alternatives.  Either convert fault planes to horizons (not practical for unassigned 
faults) and then proceed as for horizon depth conversion (above), OR quickly and 
easily create pseudowells and populate them with TD Charts that may be extracted 
from the T-D data type.  We will illustrate the latter option.  

 
2a)  Creating / loading pseudowells:  Summary:  Export seismic navigation data at an 

appropriate SP increment in ascii format, then open the ascii file in Excel and modify 
it to include all essential data required to load wells, then load the ascii data so that 
each exported seismic SP becomes a pseudowell: 

 
Surveys > Survey Annotation:   
 

Text Options:  Display line name and SP annotation text every 200th SP 
 

Line Options:  Display survey line and survey symbols every 200th SP 
 

Surveys > Export > World Coordinates:  
 

Select data format: Line Trace X Y 
 
Select output format:  Space 
 
Select surveys (for example, L-1) 
 



Select output range:  Export world coordinates using current basemap annotation 
 
Click “OK”, browse to an appropriate directory, name file “exported nav.dat” 
 
The exported nav data looks like the illustration shown below: 
 

 
Figure 2:  Example of ascii seismic navigation data exported for every 200th shotpoint 
 
 
Open Microsoft Excel, then click File > Open  and select “exported nav.dat” 
 
 Change the selection of “Files of type:” at the bottom of the browser to “All files” 
 
 This action opens Excel’s Text Import Wizard (note Step 1 of 3) 
 
 Original data type:  Select “Delimited” 
 
 Start import at row 1 (no header lines), click “Next”… 
 
 Select “Space” as the only delimiter, then click “Finish” 
 
 Format each of the four columns appropriately: 
 
  Format > Cells > Number > Decimal places > 2 (for example) 
 
 Insert row at top and name columns A-D as “Line”, “SP”, “X” and “Y”, respectively 
 
 Insert three new columns between “SP” and “X” 
 
 Name these new columns “UWI”, “KB” and “TD” 
 
 We now have seven columns: 
 
 A = “Line”, B = “SP”, C = “UWI”, D = “KB”, E = “TD”, F = “X” and G = “Y” 
 
 Create a unique well identifier for each pseudo well by combining Line and SP: 
 
  In “UWI” column, type the formula:  =A2&"_"&B2  
 
  This naming convention will concatenate the values in columns A and B 
 
  These values are joined by the character shown in quotation marks 
 
  Highlight formula, drag to the bottom of column C, then click Control-D 
 



 Set value of Column D2 (KB elevation) to 0 (sea level) and copy down for all cells 
 
 Set value of Column E2 (TD) to 20000 (20 km) and copy down for all cells 
 

When you have successfully copied down all cells your Excel spreadsheet will 
look like Figure 3. 

 
 

 
  
Figure 3:  Example of an Excel spreadsheet built from exported seismic navigation data 

and modified to create an ascii import file for pseudowells located every 200 
shotpoints along the seismic line of interest. 

 
 

Save the spreadsheet in .xls (Excel) format giving it an appropriate name 
 
 Open Notepad 
 

Copy and paste all seven columns of data into Notepad  
 
Include the header row if you wish to preserve this information 
 
Save document (.dat format) with appropriate name for ascii import file 
 
 Save As > “exported_nav_as_pseudowells.dat” 

 
 Now we can import the nav data as pseudowells: 
 
  Wells > Import > Wells:  click OK in the Well Import wizard 
 
  In the File Import / Export dialog click on the Browse button 
 
  In the Open Well Data File dialog change “Files of Type” to “Other Files” 



 
  Browse to the appropriate directory and select the file to be imported: 
 
   “exported_nav_as_pseudowells.dat” 
 
  Click Open, then Next 
 
  Accept default to “Use UWI as it exists in import data”, then click Next… 
 

This action opens the “Import Well Information File” dialog, and should 
look like Figure 4. 

 
 

 
 
Figure 4:  The Import Well Information File dialog as it looks upon import of the ascii well 

import file shown in Figure 3. 
 
 
  Begin the import process by skipping one line (the header row) 
 
  In the Selection List click on “Well Name” 
 
  Edit the color-filled column so that it paints only the LINE text 
 

Now click on “Well Number” in the Selection List 
 
  Edit the color-filled column so that it paints only the SP values 
 

Now click on “Borehole UWI”  in the Selection List 
 
  Edit the color-filled column so that it paints only the UWI values 



 
Now scroll down quite a way in the Selection List and click on “Elevation” 

(not Elevation Reference) 
 
  Edit the color-filled column so that it paints only the KB values 

 
Just above “Elevation” in the Selection List click on “Total Depth” 

 
   Edit the color-filled column so that it paints only the TD values 
 

  Finally, scroll up a bit and do the same for “X Location” and “Y Location” 
 

   
Tip:  You may wish to scroll up and down the vertical range of your 
import data to insure that none of the data values lie outside the range 
that is painted by the import wizard.  In some cases you may wish to exit 
the wizard in order to manually edit the import file (a space here and 
there can fix most allignment problems).  In other cases you may wish to 
re-export the data from Excel in .prn format in order to force a fixed width 
to your data columns. 

 
  When you’ve verified that the columns are properly painted, click OK 
 
  Review the Define Coordinate System of Imported Data and click OK 
 
  Select a Well Import Option (a “merge” option);  Add/Update, click Next  
 
  Click Next as no additional changes are needed to Data Import Options 
 
  In the Select Depth/Time Type dialog select MD and click Next 
 
  Click Next to default values for Well Import Area Limit options 
 
  Review Selection Summary and then click Next to initiate well import 
 
  Review Import Report, then click Finish to finalize well import 
 

Verify in the base map that the pseudo wells have been imported (you 
may wish to display them by UWI instead of by Well Name) 

 
   Wells > Post Data on Map > Well Information > UWI 
   

Verify that the pseudowells display in vertical profiles (they should only 
post on the ruler at the top of time displays since not TD Chart has 
yet been loaded) 

 
 
2b)  Extracting single traces from our T-D data and loading them as TD Charts for 

pseudowells: Summary: For any given SP that correlates with a pseudowell we will 
extract the T-D data type as a trace, save it as a text file and then import it into the 
pseudowell as a TD Chart 

 
Project > TracePAK > Process Single Trace 
 

In the Trace Selection dialog select the desired Survey and SP values 
 



Then select the Seismic Data Type as “T-D”, then click Process 
 
Verify that the Process Trace dialog shows a correct time-depth curve 
 
Save the time-depth curve by clicking Trace > Export Text  
 
Browse to an appropriate directory and give the trace a name 
 
Repeat the last steps to extract and save other traces 
 

Now the T-D traces can be loaded as TD Charts for the pseudowells 
 
   In Base Map, Wells > Edit > T/D Charts > verify well selection on list, or 
   In Base Map, double-click on desired well > Borehole  > T/D Charts, or 
   In Vertical Profile, right click on well symbol > Edit Time-Depth Charts… 
 
   In the Time-Depth Charts dialog go to File > Open… 
 
   In the Open dialog, browse to the appropriate directory 
 
   Select the ascii T-D trace that was exported for this pseudowell 
 
   Note that you may have to select the file type Other Files (*.*) 
 
   Click “Open” to begin the ascii loading wizard 
 
   Skip the appropriate number of header lines 
 
   Select Time (seconds) as the Z type for Column 1 (Time/Depth) 
 
   Select MD or TVD (they’re the same since KB = 0) for Column 2 
 
   Scroll down to insure that the columns are painted correctly 
 
   Click OK to finish import and OK to respond to extrapolation warning 
 
   Click OK to close the Time-Depth Charts dialog  
    
   Click Yes to apply the changes 
 
   Click OK once more to respond to a redundant extrapolation warning 
 
   Click Yes to overwrite the existing Time-Depth Chart 
 
   The borehole of the pseudowell should now display in time sections 
 
   Repeat the loading process for other pseudowells 

 
 
2c)  Depth-converting faults using local and / or shared TD Charts 

 
Simply go to Faults > Convert Fault Surfaces - Time < > Depth 

 
 In the dialog select the wells to use (all?) and the faults to convert (all?) 
 
 Be sure to make the radio button selection for Time-to-Depth or Depth-to-Time 



 
 Click OK;  the depth-converted faults should now display in a depth profile 

 
  

Summary:   
 
The workflows documented above illustrate in detail the conversion of seismic traces, horizons 
and faults from time domain to depth domain.  Several options are prescribed to match the data 
available for conversion to specific workflows.  In each case presented the depth conversion of 
the interpretation products is consistent with the depth-converted seismic traces. 
 


